using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""[^""]*""|'[^']*'|\s+AS\s+|\s*((?:(?!\sAS\s)[^\s,])+)";
string input = @"Select id AS ""cusId "", name as 'cusName', gendar as ' Gendar.', isPaid as "" is'Paid "" total , datetime FROM";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}