$re = '/"[^"]*"|\'[^\']*\'|\s+AS\s+|\s*((?:(?!\sAS\s)[^\s,])+)/i';
$str = 'Select id AS "cusId ", name as \'cusName\', gendar as \' Gendar.\', isPaid as " is\'Paid " total , datetime FROM';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);