import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"[^\"]*\"|'[^']*'|\\s+AS\\s+|\\s*((?:(?!\\sAS\\s)[^\\s,])+)";
final String string = "Select id AS \"cusId \", name as 'cusName', gendar as ' Gendar.', isPaid as \" is'Paid \" total , datetime FROM";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}