using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\(trading as[^()]*\)|\b([A-Z0-9-](?:[A-Z0-9 \t&.-](?:\s*\(\d+\))?)*)(?:\b|(?<=\)))";
string input = @"TEST LIMITED (trading as FOO Limited) (in relation), TEST (2005) LTD, WINDING LIMITED (in liquidation)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}