import re
regex = re.compile(r"\(trading as[^()]*\)|\b([A-Z0-9-](?:[A-Z0-9 \t&.-](?:\s*\(\d+\))?)*)(?:\b|(?<=\)))", flags=re.MULTILINE)
test_str = "TEST LIMITED (trading as FOO Limited) (in relation), TEST (2005) LTD, WINDING LIMITED (in liquidation)"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")