$re = '/\(trading as[^()]*\)|\b([A-Z0-9-](?:[A-Z0-9 \t&.-](?:\s*\(\d+\))?)*)(?:\b|(?<=\)))/m';
$str = 'TEST LIMITED (trading as FOO Limited) (in relation), TEST (2005) LTD, WINDING LIMITED (in liquidation)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);