package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.+/)??([^#\s/]+)?(?:#([^\s\(]+(?:\([^\)]*\))?))?(?: +([^\s/]+)\s*)?$`)
var str = `String#test
my.module/com.java.lang.String
#test
#method(int m, int n)
String#method(int,String)
String
String label`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}