$re = '/^(.+/)??([^#\s/]+)?(?:#([^\s\(]+(?:\([^\)]*\))?))?(?: +([^\s/]+)\s*)?$/m';
$str = 'String#test
my.module/com.java.lang.String
#test
#method(int m, int n)
String#method(int,String)
String
String label';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);