re = /^(.+\/)??([^#\s\/]+)?(?:#([^\s\(]+(?:\([^\)]*\))?))?(?: +([^\s\/]+)\s*)?$/m
str = 'String#test
my.module/com.java.lang.String
#test
#method(int m, int n)
String#method(int,String)
String
String label'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end