#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(проезд|пл|пр-кт|пер|наб|линия|км|б-р|аллея|кв-л)\s(.*[^)\r\n])$"
Local $sString = "проезд Волокойёламский Большой" & @CRLF & _
"аллея 11-ти Героев Сапёров" & @CRLF & _
"аллея Беговая" & @CRLF & _
"аллея Берёзовая (ЗелАО)" & @CRLF & _
"б-р Большой (тер. ИЦ «Сколково»)" & @CRLF & _
"б-р Волжский" & @CRLF & _
"кв-л Самаркандский бульв., 134а" & @CRLF & _
"км МКАД 100-й" & @CRLF & _
"линия Савёловская" & @CRLF & _
"линия Северная 1-я" & @CRLF & _
"линия Хорошёвского Серебряного Бора 1-я" & @CRLF & _
"наб Крутицкая" & @CRLF & _
"пер 800-летия Москвы" & @CRLF & _
"пер Абрикосовский" & @CRLF & _
"пер Богородский 2-й (г. Троицк)" & @CRLF & _
"пл 60-летия СССР" & @CRLF & _
"пл Абельмановская Застава" & @CRLF & _
"пр-кт 60-летия Октября (пос. Абабурово)" & @CRLF & _
"пр-кт Академика Сахарова" & @CRLF & _
"пр-кт Андропова" & @CRLF & _
"проезд Академический" & @CRLF & _
"проезд Александровский (дер. Зверево)" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")