use strict;
my $str = 'проезд Волокойёламский Большой
аллея 11-ти Героев Сапёров
аллея Беговая
аллея Берёзовая (ЗелАО)
б-р Большой (тер. ИЦ «Сколково»)
б-р Волжский
кв-л Самаркандский бульв., 134а
км МКАД 100-й
линия Савёловская
линия Северная 1-я
линия Хорошёвского Серебряного Бора 1-я
наб Крутицкая
пер 800-летия Москвы
пер Абрикосовский
пер Богородский 2-й (г. Троицк)
пл 60-летия СССР
пл Абельмановская Застава
пр-кт 60-летия Октября (пос. Абабурово)
пр-кт Академика Сахарова
пр-кт Андропова
проезд Академический
проезд Александровский (дер. Зверево)
';
my $regex = qr/^(проезд|пл|пр-кт|пер|наб|линия|км|б-р|аллея|кв-л)\s(.*[^)\r\n])$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}