package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(проезд|пл|пр-кт|пер|наб|линия|км|б-р|аллея|кв-л)\s(.*[^)\r\n])$`)
var str = `проезд Волокойёламский Большой
аллея 11-ти Героев Сапёров
аллея Беговая
аллея Берёзовая (ЗелАО)
б-р Большой (тер. ИЦ «Сколково»)
б-р Волжский
кв-л Самаркандский бульв., 134а
км МКАД 100-й
линия Савёловская
линия Северная 1-я
линия Хорошёвского Серебряного Бора 1-я
наб Крутицкая
пер 800-летия Москвы
пер Абрикосовский
пер Богородский 2-й (г. Троицк)
пл 60-летия СССР
пл Абельмановская Застава
пр-кт 60-летия Октября (пос. Абабурово)
пр-кт Академика Сахарова
пр-кт Андропова
проезд Академический
проезд Александровский (дер. Зверево)
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}