using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bSalutation:.*?\sx\s(M(?:rs?|x)\.)";
string input = @"Salutation: Mr. x Mx. Mrs.
Salutation: Mr. Mx. x Mrs.
Salutation: Mr. Mx. x Mr.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}