$re = '/\bSalutation:.*?\sx\s(M(?:rs?|x)\.)/m';
$str = 'Salutation: Mr. x Mx. Mrs.
Salutation: Mr. Mx. x Mrs.
Salutation: Mr. Mx. x Mr.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);