re = /\bSalutation:.*?\sx\s(M(?:rs?|x)\.)/m
str = 'Salutation: Mr. x Mx. Mrs.
Salutation: Mr. Mx. x Mrs.
Salutation: Mr. Mx. x Mr.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end