using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\b|_)\p{L}{2}\p{N}{3,5}(?=\b|_)";
string input = @"foo-foo_AB1234_foo_AB12345678_string";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}