$re = '/(?<=\b|_)\p{L}{2}\p{N}{3,5}(?=\b|_)/';
$str = 'foo-foo_AB1234_foo_AB12345678_string';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);