re = /(?<=\b|_)\p{L}{2}\p{N}{3,5}(?=\b|_)/
str = 'foo-foo_AB1234_foo_AB12345678_string'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end