const regex = /\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b', 'g')
const str = `#stack###over##flow`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);