using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"play\s*(.*?)\s*in";
string input = @"play the Ukulele in Lebanon. play the Guitar in Lebanon.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}