package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`play\s*(.*?)\s*in`)
var str = `play the Ukulele in Lebanon. play the Guitar in Lebanon.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}