#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<seperator>(?:[^\S]|[.:,-\/—;_])*)(?<value>((([+|-|.]*(\$|\%|(C\$)|(\€))*(?:\d+[.,']*\d*[.,']{0,1})+[?:mkC\%\€\$\£]*([?:mkC\%\€\$\£]|C\$)*))?))"
Local $sString = " . . . .45" & @CRLF & _
" .45 " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" ---,,,... 1.123" & @CRLF & _
" "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")