using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<seperator>(?:[^\S]|[.:,-\/—;_])*)(?<value>((([+|-|.]*(\$|\%|(C\$)|(\€))*(?:\d+[.,']*\d*[.,']{0,1})+[?:mkC\%\€\$\£]*([?:mkC\%\€\$\£]|C\$)*))?))";
string input = @" . . . .45
.45
---,,,... 1.123
";
RegexOptions options = RegexOptions.Multiline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}