// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?<seperator>(?:[^\S]|[.:,-\/—;_])*)(?<value>((([+|-|.]*(\$|\%|(C\$)|(\€))*(?:\d+[.,']*\d*[.,']{0,1})+[?:mkC\%\€\$\£]*([?:mkC\%\€\$\£]|C\$)*))?))").unwrap();
let string = " . . . .45
.45
---,,,... 1.123
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}