#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.*[a-z])(?=.*[A-Z])(?=.*\d)[\w!@#$%^&*?~()-]{8,}$"
Local $sString = "ABC" & @CRLF & _
"Ab345678" & @CRLF & _
"Ab3()&%!" & @CRLF & _
"Ab34567=" & @CRLF & _
"ABCDEFGH" & @CRLF & _
"abcdefgh" & @CRLF & _
"12345678" & @CRLF & _
"äbcdeFG8"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")