$re = '/^(?=.*[a-z])(?=.*[A-Z])(?=.*\d)[\w!@#$%^&*?~()-]{8,}$/m';
$str = 'ABC
Ab345678
Ab3()&%!
Ab34567=
ABCDEFGH
abcdefgh
12345678
äbcdeFG8';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);