re = /^(?=.*[a-z])(?=.*[A-Z])(?=.*\d)[\w!@#$%^&*?~()-]{8,}$/m
str = 'ABC
Ab345678
Ab3()&%!
Ab34567=
ABCDEFGH
abcdefgh
12345678
äbcdeFG8'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end