#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)<a(?: [^>]+)?>(?:<[a-z][^>]*>)*(.*?)(?:<\/[a-z][^>]*>)*<\/a>"
Local $sString = "<a href="asdf"><a href="here"><span class="tocnumber">2</span> <span class="toctext">IELTS test structure</span></a>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")