$re = '/<a(?: [^>]+)?>(?:<[a-z][^>]*>)*(.*?)(?:<\/[a-z][^>]*>)*<\/a>/i';
$str = '<a href="asdf"><a href="here"><span class="tocnumber">2</span> <span class="toctext">IELTS test structure</span></a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);