re = /<a(?: [^>]+)?>(?:<[a-z][^>]*>)*(.*?)(?:<\/[a-z][^>]*>)*<\/a>/i
str = '<a href="asdf"><a href="here"><span class="tocnumber">2</span> <span class="toctext">IELTS test structure</span></a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end