# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?!^((([A-Za-z]{3,9}:(?:\\/\\/)?)(?:[-;:&=\+\$,\w]+@)?[A-Za-z0-9.-]+|(?:www.|[-;:&=\+\$,\w]+@)[A-Za-z0-9.-]+)((?:\\/[\+~%\\/.\w-_]*)?\??(?:[-\+=&;%@.\w_]*)#?(?:[\w]*))?)$).*$//gm;t' <<< "www.google.com
http://www.google.com
hjsgjhadg
adjgdsjhd
mailto:somebody@google.com
somebody@google.com
www.url-with-querystring.com/?url=has-querystring
"