use strict;
my $str = 'www.google.com
http://www.google.com
hjsgjhadg
adjgdsjhd
mailto:somebody@google.com
somebody@google.com
www.url-with-querystring.com/?url=has-querystring
';
my $regex = qr/^(?!^((([A-Za-z]{3,9}:(?:\/\/)?)(?:[-;:&=\+\$,\w]+@)?[A-Za-z0-9.-]+|(?:www.|[-;:&=\+\$,\w]+@)[A-Za-z0-9.-]+)((?:\/[\+~%\/.\w-_]*)?\??(?:[-\+=&;%@.\w_]*)#?(?:[\w]*))?)$).*$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";