#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?!^((([A-Za-z]{3,9}:(?:\/\/)?)(?:[-;:&=\+\$,\w]+@)?[A-Za-z0-9.-]+|(?:www.|[-;:&=\+\$,\w]+@)[A-Za-z0-9.-]+)((?:\/[\+~%\/.\w-_]*)?\??(?:[-\+=&;%@.\w_]*)#?(?:[\w]*))?)$).*$"
Local $sString = "www.google.com" & @CRLF & _
"http://www.google.com" & @CRLF & _
"hjsgjhadg" & @CRLF & _
"adjgdsjhd" & @CRLF & _
"mailto:somebody@google.com" & @CRLF & _
"somebody@google.com" & @CRLF & _
"www.url-with-querystring.com/?url=has-querystring" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)