const regex = /[A-Z]\S+(?:\s[A-Z]\S+)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[A-Z]\\S+(?:\\s[A-Z]\\S+)?', 'gm')
const str = `Harry Potter is a wizard
Ronald had a Broom and a Ford Car`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}