$re = '/[A-Z]\S+(?:\s[A-Z]\S+)?/m';
$str = 'Harry Potter is a wizard
Ronald had a Broom and a Ford Car';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);