// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[A-Z]\S+(?:\s[A-Z]\S+)?").unwrap();
let string = "Harry Potter is a wizard
Ronald had a Broom and a Ford Car";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}