const regex = /(file_exists|is_file)(\(((?>[^()]++|(?2))*)\))/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(file_exists|is_file)(\\(((?>[^()]++|(?2))*)\\))', '')
const str = `if (is_file(str_replace(array(), array(), strtolower(\$file))){`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}