import Foundation
let pattern = #"(file_exists|is_file)(\(((?>[^()]++|(?2))*)\))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"if (is_file(str_replace(array(), array(), strtolower($file))){"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}