re = /(file_exists|is_file)(\(((?>[^()]++|(?2))*)\))/
str = 'if (is_file(str_replace(array(), array(), strtolower($file))){'
# Print the match result
str.match(re) do |match|
puts match.to_s
end