package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[[\d\.]+\] (\d{2,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})[\,:\s\[\]\d{1,2}\w]+([\d\.]{4,7})+[\w\s\d\(\)\.,%]+`)
var str = `traceroute to 10.20.5.111 (10.20.5.111), 30 hops max, 60 byte packets
1 10.194.82.1 (10.194.82.1) 0.149 ms 0.139 ms 0.138 ms
2 10.194.202.97 (10.194.202.97) 0.454 ms 0.499 ms 0.546 ms
3 10.219.244.81 (10.219.244.81) 0.791 ms 0.792 ms 0.805 ms
4 10.207.187.37 (10.207.187.37) 39.497 ms 39.489 ms 39.490 ms
5 10.207.187.38 (10.207.187.38) 38.442 ms 39.839 ms 41.330 ms
6 10.20.5.111 (10.20.5.111) 42.867 ms 43.448 ms 44.847 ms`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}