use strict;
my $str = 'traceroute to 10.20.5.111 (10.20.5.111), 30 hops max, 60 byte packets
1 10.194.82.1 (10.194.82.1) 0.149 ms 0.139 ms 0.138 ms
2 10.194.202.97 (10.194.202.97) 0.454 ms 0.499 ms 0.546 ms
3 10.219.244.81 (10.219.244.81) 0.791 ms 0.792 ms 0.805 ms
4 10.207.187.37 (10.207.187.37) 39.497 ms 39.489 ms 39.490 ms
5 10.207.187.38 (10.207.187.38) 38.442 ms 39.839 ms 41.330 ms
6 10.20.5.111 (10.20.5.111) 42.867 ms 43.448 ms 44.847 ms';
my $regex = qr/\[[\d\.]+\] (\d{2,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})[\,:\s\[\]\d{1,2}\w]+([\d\.]{4,7})+[\w\s\d\(\)\.,%]+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}