import re
regex = re.compile(r"\[[\d\.]+\] (\d{2,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})[\,:\s\[\]\d{1,2}\w]+([\d\.]{4,7})+[\w\s\d\(\)\.,%]+", flags=re.MULTILINE)
test_str = ("traceroute to 10.20.5.111 (10.20.5.111), 30 hops max, 60 byte packets\n"
" 1 10.194.82.1 (10.194.82.1) 0.149 ms 0.139 ms 0.138 ms\n"
" 2 10.194.202.97 (10.194.202.97) 0.454 ms 0.499 ms 0.546 ms\n"
" 3 10.219.244.81 (10.219.244.81) 0.791 ms 0.792 ms 0.805 ms\n"
" 4 10.207.187.37 (10.207.187.37) 39.497 ms 39.489 ms 39.490 ms\n"
" 5 10.207.187.38 (10.207.187.38) 38.442 ms 39.839 ms 41.330 ms\n"
" 6 10.20.5.111 (10.20.5.111) 42.867 ms 43.448 ms 44.847 ms")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")