using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*\*\s*Code\s+\""(?<Code>((\"")*[^\""]+)+)\""";
string input = @"* Code ""l;k""dfsakd;.*[])_lkaDald""
";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}