$re = '/^\s*\*\s*Code\s+\"(?<Code>((\")*[^\"]+)+)\"/x';
$str = '* Code "l;k""dfsakd;.*[])_lkaDald"
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);