package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\s*\*\s*Code\s+\"(?<Code>((\")*[^\"]+)+)\"`)
var str = `* Code "l;k""dfsakd;.*[])_lkaDald"
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}