#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?!acteur:).*(*SKIP)(*F)|(?:^acteur:\h+|\h+)"
Local $sString = "acteur: 634, 681, 731" & @CRLF & _
"inbob: -1" & @CRLF & _
"mention: " & @CRLF & _
"Il n'est pas distingué" & @CRLF & _
"acteur: 731" & @CRLF & _
"lieu: " & @CRLF & _
"editeur: Les étoiles de la chanson" & @CRLF & _
"collection: " & @CRLF & _
"numed: " & @CRLF & _
"nbv: " & @CRLF & _
"nbp: " & @CRLF & _
"date: [1934]" & @CRLF & _
"date2: 1934" & @CRLF & _
"(:remarque:Deuxième vérification faite : ok:)");" & @CRLF & _
"" & @CRLF & _
"type: " & @CRLF & _
"inbob: -1" & @CRLF & _
"mention: " & @CRLF & _
"Comme un moineau" & @CRLF & _
"acteur: 634, 681, 731" & @CRLF & _
"lieu: " & @CRLF & _
"editeur: Les étoiles de la chanson" & @CRLF & _
"collection: " & @CRLF & _
"numed: " & @CRLF & _
"nbv: " & @CRLF & _
"nbp: " & @CRLF & _
"date: [1930]" & @CRLF & _
"date2: 1930" & @CRLF & _
"(:remarque::)");"
Local $sSubst = "Acteur."
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)