import Foundation
let pattern = #"^(?!acteur:).*(*SKIP)(*F)|(?:^acteur:\h+|\h+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
acteur: 634, 681, 731
inbob: -1
mention:
Il n'est pas distingué
acteur: 731
lieu:
editeur: Les étoiles de la chanson
collection:
numed:
nbv:
nbp:
date: [1934]
date2: 1934
(:remarque:Deuxième vérification faite : ok:)");
type:
inbob: -1
mention:
Comme un moineau
acteur: 634, 681, 731
lieu:
editeur: Les étoiles de la chanson
collection:
numed:
nbv:
nbp:
date: [1930]
date2: 1930
(:remarque::)");
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"Acteur."#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)