re = /^(?!acteur:).*(*SKIP)(*F)|(?:^acteur:\h+|\h+)/m
str = 'acteur: 634, 681, 731
inbob: -1
mention:
Il n\'est pas distingué
acteur: 731
lieu:
editeur: Les étoiles de la chanson
collection:
numed:
nbv:
nbp:
date: [1934]
date2: 1934
(:remarque:Deuxième vérification faite : ok:)");
type:
inbob: -1
mention:
Comme un moineau
acteur: 634, 681, 731
lieu:
editeur: Les étoiles de la chanson
collection:
numed:
nbv:
nbp:
date: [1930]
date2: 1930
(:remarque::)");'
subst = 'Acteur.'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result