import re
regex = re.compile(r".*?>", flags=re.MULTILINE)
test_str = ("30049988.html\" >Title1\n"
"297816.html\" >Title2\n"
"2979922.html\" >Title3\n"
"29736.html\" >Title4\n"
"22833.html\" >Title5")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)