#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^5((0[0-9]|[3-5]\d)|(92)) \d{3} \d{4}$"
Local $sString = "Turkcell" & @CRLF & _
"" & @CRLF & _
"530 123 4567" & @CRLF & _
"531 123 4567" & @CRLF & _
"532 123 4567" & @CRLF & _
"533 123 4567" & @CRLF & _
"534 123 4567" & @CRLF & _
"535 123 4567" & @CRLF & _
"536 123 4567" & @CRLF & _
"537 123 4567" & @CRLF & _
"538 123 4567" & @CRLF & _
"539 123 4567" & @CRLF & _
"" & @CRLF & _
"Türk Telekom Mobil" & @CRLF & _
"" & @CRLF & _
"500 123 4567" & @CRLF & _
"501 123 4567" & @CRLF & _
"502 123 4567" & @CRLF & _
"503 123 4567" & @CRLF & _
"504 123 4567" & @CRLF & _
"505 123 4567" & @CRLF & _
"506 123 4567" & @CRLF & _
"507 123 4567" & @CRLF & _
"508 123 4567" & @CRLF & _
"509 123 4567" & @CRLF & _
"" & @CRLF & _
"550 123 4567" & @CRLF & _
"551 123 4567" & @CRLF & _
"552 123 4567" & @CRLF & _
"553 123 4567" & @CRLF & _
"554 123 4567" & @CRLF & _
"555 123 4567" & @CRLF & _
"556 123 4567" & @CRLF & _
"557 123 4567" & @CRLF & _
"558 123 4567" & @CRLF & _
"559 123 4567" & @CRLF & _
"" & @CRLF & _
"Vodafone" & @CRLF & _
"" & @CRLF & _
"540 123 4567" & @CRLF & _
"541 123 4567" & @CRLF & _
"542 123 4567" & @CRLF & _
"543 123 4567" & @CRLF & _
"544 123 4567" & @CRLF & _
"545 123 4567" & @CRLF & _
"546 123 4567" & @CRLF & _
"547 123 4567" & @CRLF & _
"548 123 4567" & @CRLF & _
"549 123 4567" & @CRLF & _
"" & @CRLF & _
"Globalstar" & @CRLF & _
"" & @CRLF & _
"592 211 9999" & @CRLF & _
"592 212 0888" & @CRLF & _
"" & @CRLF & _
"Teknomobil" & @CRLF & _
"" & @CRLF & _
"592 113 0900" & @CRLF & _
"592 113 1900" & @CRLF & _
"592 113 2900" & @CRLF & _
"592 113 3900" & @CRLF & _
"592 113 4900" & @CRLF & _
"592 113 5900" & @CRLF & _
"592 113 6900" & @CRLF & _
"592 110 0900" & @CRLF & _
"592 110 1900" & @CRLF & _
"592 110 2900" & @CRLF & _
"592 110 3900" & @CRLF & _
"592 110 4900" & @CRLF & _
"592 110 5900" & @CRLF & _
"592 110 6900" & @CRLF & _
"" & @CRLF & _
"TB Haberleşme" & @CRLF & _
"" & @CRLF & _
"592 616 0900" & @CRLF & _
"592 616 1900" & @CRLF & _
"592 616 2900" & @CRLF & _
"592 616 3900" & @CRLF & _
"592 616 4900" & @CRLF & _
"" & @CRLF & _
"Medium Telekom" & @CRLF & _
"" & @CRLF & _
"592 216 9999"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")